Ir para conteúdo






Foto

Seu servidor web está configurado incorretamente...

servidor incorretamente erro magento hospedagem

  • Por favor, faça o login para responder
8 respostas neste tópico

#1 Bruno Costa Sampaio

Bruno Costa Sampaio

    Membro Avançado

  • Membros
  • PipPipPip
  • 44 posts

Postado 05 março 2014 - 10:04

Olá, bom dia!

 

Estou com uma mensagem aparecendo no admin da loja, e não sei o que fazer, já que o provedor de hospedagem disse que está tudo ok e possivelmente essa mensagem, é na configuração da loja.

 

Segue mensagem:

 

"Seu servidor web está configurado incorretamente. Como resultado, os arquivos de configuração com informações confidenciais são acessíveis de fora. Entre em contato com seu provedor de hospedagem".

 

Alguém sabe me dizer o que posso fazer para resolver isso?

 

Obrigado, abraço.

Bruno C.

 

 

 

 



#2 Marcelo - cerebrum.com.br

Marcelo - cerebrum.com.br

    Administrator

  • Administrators
  • 1.090 posts

Postado 05 março 2014 - 10:09

Ola Bruno Costa Sampaio,

 

Tente resetar as permissões.

 

https://www.magentoc...ile_permissions


:: https://www.cerebrum.com.br/?p=454 - MÓDULOS PARA MAGENTO
:: https://www.cerebrum.com.br/?p=462 - NOVO MÓDULO DA CIELO PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=507 - NOVO MÓDULO DA PAGSEGURO PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=495 - NOVO MÓDULO DA BRASPAG PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=509 - NOVO MÓDULO DA MÓDULO DA REDE / WEBSERVICE KOMERCI PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=726 - NOVO MÓDULO DO ITAÚ PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=731 - NOVO MÓDULO DO BRADESCO SHOPFÁCIL PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=736 - NOVO MÓDULO DO BANCO DO BRASIL PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=709 - NOVO MÓDULO DOS CORREIOS PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=487 - NOVO MÓDULO DOS CORREIOS EXPORTA FÁCIL PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=503 - NOVO MÓDULO JAMEF PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=501 - NOVO MÓDULO DA JADLOG PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=513 - NOVO MÓDULO DE CÁLCULO DE FRETE NA PÁGINA DO PRODUTO PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=497 - NOVO MÓDULO DA CLEARSALE PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=511 - NOVO MÓDULO DE CADASTRO DE CLIENTES PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=1870 - NOVO MÓDULO DA LOGGI PARA MAGENTO 1.x
:: https://www.cerebrum.com.br/?p=3804 - MAESTRO - Renomada metodologia de desenvolvimento de loja virtual Magento
 

#3 Bruno Costa Sampaio

Bruno Costa Sampaio

    Membro Avançado

  • Membros
  • PipPipPip
  • 44 posts

Postado 05 março 2014 - 10:21

Ok Marcelo, vou ver se consigo.

 

Obrigado.



#4 Bruno Costa Sampaio

Bruno Costa Sampaio

    Membro Avançado

  • Membros
  • PipPipPip
  • 44 posts

Postado 13 março 2014 - 09:12

Marcelo, bom dia!

 

Não consegui achar onde faço isso, resetar essas permissões, qual é o caminho?

 

Obrigado.



#5 Lojas RPM

Lojas RPM

    Membro Avançado

  • Membros
  • PipPipPip
  • 83 posts

Postado 25 março 2014 - 11:21

Estou com o mesmo problema.



#6 pauloboaventura

pauloboaventura

    Novo Usuário

  • Membros
  • Pip
  • 4 posts

Postado 10 fevereiro 2018 - 03:37

E ninguém responde... 
 

Estou com o mesmo problema...
Creio que coloquei .htaccess em locais que não deveria... 

Vou procurar a solução na internet né...



#7 Ariel Cugenotta

Ariel Cugenotta

    Membro Avançado

  • Membros
  • PipPipPip
  • 110 posts
  • LocalizaçãoSão Paulo / SP

Postado 10 fevereiro 2018 - 10:20

Olá pessoal.

 

Isso aconteceu comigo quando a loja estava no ambiente Windows, se esse for o caso de vocês eu aconselho que migrem para o Linux.

Esse problema não é de programação, mas sim de ambiente, controlado pelo Apache ou Nginx e .htaccess.

 

Certifique-se de que as pastas estão setadas com permissão 755 e os arquivos 644, com os comandos abaixo é possível setar essas permissões de uma só vez (via SSH).

 

Comando para alterar as permissões dos diretórios:
find * -type d -print0 | xargs -0 chmod 0755

Comando para alterar as permissões dos arquivos:
find . -type f -print0 | xargs -0 chmod 0644

 

Outro ponto é a pasta app esta com o .htaccess negando a permissão de acesso, conforme mostro abaixo:

Order deny,allow
Deny from all

Também verifique se ao acessar a pasta http://seudominio.com.br/var/ esta listando no navegador as pastas e arquivos, pois se tiver solicite a hospedagem a correção e adicione o comando abaixo no .htaccess que fica na raiz de intalação da loja:

Options +FollowSymLinks

Te ajudei? Se inscreve em meu Canal sobre Magento 2!
 
Canal Mestre Magento
Novos Vídeos toda Segunda e Quinta

#8 pauloboaventura

pauloboaventura

    Novo Usuário

  • Membros
  • Pip
  • 4 posts

Postado 13 fevereiro 2018 - 01:58

Obrigado por responder tao prontamente...
Bom o que falou esta correto.

Mas no meu caso foi o seguinte:
 

Causa

Esse problema ocorre porque as permissões de arquivos estão incorretas, ou porque há um arquivo .htaccess faltando no subdiretório app da instalação Magento.

Resolução

Para resolver este problema, siga estes passos abaixo:

  1. Confirmar que existe um arquivo .htaccess no subdiretório app da instalação Magento. Se o arquivo .htaccessestá faltando, criar um novo arquivo .htaccess no subdiretório aplicativo que contém as seguintes diretrizes:

    Order deny,allow
    Deny from all

 

 

 

 

Olá pessoal.

 

Isso aconteceu comigo quando a loja estava no ambiente Windows, se esse for o caso de vocês eu aconselho que migrem para o Linux.

Esse problema não é de programação, mas sim de ambiente, controlado pelo Apache ou Nginx e .htaccess.

 

Certifique-se de que as pastas estão setadas com permissão 755 e os arquivos 644, com os comandos abaixo é possível setar essas permissões de uma só vez (via SSH).

 

Comando para alterar as permissões dos diretórios:
find * -type d -print0 | xargs -0 chmod 0755

Comando para alterar as permissões dos arquivos:
find . -type f -print0 | xargs -0 chmod 0644

 

Outro ponto é a pasta app esta com o .htaccess negando a permissão de acesso, conforme mostro abaixo:

Order deny,allow Deny from all

Também verifique se ao acessar a pasta http://seudominio.com.br/var/ esta listando no navegador as pastas e arquivos, pois se tiver solicite a hospedagem a correção e adicione o comando abaixo no .htaccess que fica na raiz de intalação da loja:

Options +FollowSymLinks

 



#9 Ariel Cugenotta

Ariel Cugenotta

    Membro Avançado

  • Membros
  • PipPipPip
  • 110 posts
  • LocalizaçãoSão Paulo / SP

Postado 14 fevereiro 2018 - 07:06

Legal Paulo, fico feliz que tenha dado tudo certo.

 

Tenho um canal dedicado ao Magento 2, caso queira conhecer mais sobre essa nova versão do Magento eu apresento diversas soluções gratuitas e como corrigir bugs nativos -> https://www.youtube.com/MestreMagento

 

Valeu!


Te ajudei? Se inscreve em meu Canal sobre Magento 2!
 
Canal Mestre Magento
Novos Vídeos toda Segunda e Quinta





Tópicos que também usam as tags servidor, incorretamente, erro, magento, hospedagem:

0 usuário(s) está(ão) lendo este tópico

0 membros, 0 visitantes, 0 membros anônimos